PG_CATCHECK-MASTE

PG_CATCHECK-MASTE

 1) Download pg_catcheck-master.zip from below link:

 

https://github.com/EnterpriseDB/pg_catcheck

 

unzip pg_catcheck-master.zip

 

2) Export below parameters:

 

[root@localhostpg_catcheck-master]# export LD_LIBRARY_PATH=/opt/PostgresPlus/9.3AS/lib/

[root@localhostpg_catcheck-master]# export PATH=/opt/PostgresPlus/9.3AS/bin/:$PATH

[root@localhostpg_catcheck-master]# export PG_CONFIG=/opt/PostgresPlus/9.3AS/bin/pg_config

 

3) In order to avoid error /usr/bin/ld: cannot find -lmemcached collect2: ld returned 1 exit status, copy below library.

 

[root@localhostpg_catcheck-master]# cp /opt/PostgresPlus/9.3AS/lib/libmemcached.so.10 /opt/PostgresPlus/9.3AS/lib/libmemcached.so

 

4) Please install below packages in your environment to avoid errors:

 

yum install libxslt-devel.x86_64

yum install pam-devel.x86_64

yum install openssl-devel.x86_64

yum install libedit-devel.x86_64

 

5) Build and install the software using below commands:

> make LIBS='-lpq -lpgport'

> make install

 

6) Please check the version pf pg_catcheck using below command:

 

[root@localhostpg_catcheck-master]# make install

/bin/mkdir -p '/opt/PostgresPlus/9.3AS/bin'

/usr/bin/install -c  pg_catcheck '/opt/PostgresPlus/9.3AS/bin'

[root@localhostpg_catcheck-master]# /opt/PostgresPlus/9.3AS/bin/pg_catcheck --version

pg_catcheck (EnterpriseDB) 9.3.19.44

 

-bash-4.1$ ./pg_catcheck --version

pg_catcheck (EnterpriseDB) 9.3.19.44

-bash-4.1$ pwd

/opt/PostgresPlus/9.3AS/bin

Related Posts: